Service outage
Incident Report for When I Work
Resolved
This incident has been resolved.
Posted May 24, 2017 - 16:59 CDT
Monitoring
All systems have returned to normal and we are continuing to monitor the situation.
Posted May 24, 2017 - 16:44 CDT
Investigating
We are investigating reports of users unable to log in or access the Help Center.
Posted May 24, 2017 - 16:27 CDT