Email Notification Delays
Incident Report for When I Work
Resolved
Our email delivery system has resolved any outstanding issues. When I Work email notifications are going out as normal.
Posted Jul 16, 2018 - 13:05 CDT
Identified
Our email delivery service provider is experiencing issues which is causing When I Work email notifications to be delayed by 45-60 minutes.
Posted Jul 16, 2018 - 11:50 CDT