Performance Issues: Shifts and Timesheets
Incident Report for When I Work
Resolved
The issue with creating and editing shifts and loading timesheets has been resolved. Thank you for your patience while we worked to resolve this as quickly as possible. Note: you may need to refresh your site to properly load timesheets.
Posted Jun 21, 2018 - 22:28 CDT
Identified
Our team has identified the issue and is rapidly working towards a solution.
Posted Jun 21, 2018 - 22:09 CDT
Update
Our team is continuing to investigate this issue.
Posted Jun 21, 2018 - 21:05 CDT
Investigating
We are currently investigating issues with creating and editing shifts and loading time sheets. We will post an update as soon as we have additional information.
Posted Jun 21, 2018 - 19:56 CDT
This incident affected: Web App.