Scheduled Maintenance - March 25
Incident Report for When I Work
Resolved
Woo-hoo! Nailed it. Maintenance is complete and we managed to get you back up faster than expected.
Posted Mar 25, 2018 - 06:50 CDT
Monitoring
We’re crushing this! Maintenance is going well and we’ll be back up very soon.
Posted Mar 25, 2018 - 05:45 CDT
Update
Hold on tight! Maintenance has begun. We’ll see you on the other side in about 2 hours.
Posted Mar 25, 2018 - 05:18 CDT
Update
When I Work is starting scheduled maintenance soon and will be unavailable 5:00-7:00 AM CDT.
Posted Mar 25, 2018 - 04:00 CDT
Identified
We’re making some upgrades, but this means our app will be unavailable 5:00 - 7:00 AM CDT (10:00 - 12:00 UTC) Sunday, March 25.

Real time updates during the maintenance period will be provided here on our status page.
Posted Mar 19, 2018 - 10:44 CDT