Text Message Delivery Delays
Incident Report for When I Work
Resolved
We've observed no further problems at our upstream provider.
Posted Sep 11, 2018 - 11:51 CDT
Monitoring
Our upstream provider has resolved their issue and we are continuing to monitor delivery of text messages.
Posted Sep 11, 2018 - 11:00 CDT
Identified
We are monitoring an issue at our upstream provider that is causing delays in delivering text messages (SMS).
Posted Sep 11, 2018 - 09:24 CDT