Server errors on Web and Mobile Platforms
Incident Report for When I Work
Resolved
This incident has been resolved. We apologize for the interruption to your operations and thank you for your patience.
Posted Mar 11, 2020 - 16:54 CDT
Identified
We are aware of and working quickly to resolve an issue across the web and mobile platforms. You may be seeing 502 Bad Gateway errors or other server errors while navigating the app. We will update you as soon as this is resolved.
Posted Mar 11, 2020 - 14:21 CDT
This incident affected: Web App, API, and Login.