Partial Web Outage

Incident Report for When I Work

Resolved

The incident has been resolved. Thank you for your patience.
Posted May 13, 2025 - 16:58 CDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted May 13, 2025 - 16:30 CDT

Identified

We have identified the issue causing service level degradation for Safari users, and are working on determining a fix. We will update you here once more information is available.
Posted May 13, 2025 - 15:20 CDT

Investigating

We are seeing service level degradation for users using Safari. This is actively being worked on, and we will update you here when we have more information.
Posted May 13, 2025 - 14:27 CDT
This incident affected: Web App.