Web and iOS Time Clock Outage
Incident Report for When I Work
Resolved
This incident has been resolved. Thank you again for your patience.
Posted Mar 21, 2023 - 10:31 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 10:03 CDT
Identified
We have identified the issue impacting logging into When I Work on all platforms, degraded web performance, and an issue impacting the iOS Time Clock app. We are currently working to deploy a fix. We apologize for the interruption and thank you for your patience.
Posted Mar 21, 2023 - 09:50 CDT
Investigating
We have been alerted to issues impacting logging into When I Work on all platforms, as well as an issue impacting the iOS Time Clock app. This is actively being investigated, and an update will be provided once there is more information.
Posted Mar 21, 2023 - 08:33 CDT
This incident affected: Web App and Login.