Online Ticket Submission Error
Incident Report for When I Work
Resolved
The issue with ticket submission has been resolved.
Posted Oct 15, 2018 - 10:03 CDT
Investigating
We are currently investigating an issue with support ticket submission from the help center and in app. You can reach us via chat or support@wheniwork.com while we work to resolve this.
Posted Oct 15, 2018 - 09:40 CDT