Performance Issue

Incident Report for When I Work

Resolved

The performance issues that some accounts were experiencing have been resolved. We appreciate your patience and understanding as we worked on this.
Posted Jun 09, 2025 - 10:01 CDT

Monitoring

We have released multiple fixes to address performance issues, including upgrading our Database Services. We are monitoring the results.
Posted Jun 06, 2025 - 08:40 CDT

Update

If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need further assistance, please reach out to our Care team for further investigation.
Posted Jun 03, 2025 - 14:48 CDT

Update

Intermittent performance issues have improved for the majority of customers. If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need further assistance, please reach out to our Care team.
Posted Jun 02, 2025 - 08:47 CDT

Update

Performance has improved. If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need assistance, please reach out to our Care team.
Posted May 30, 2025 - 16:00 CDT

Update

Performance has improved. If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need assistance, please reach out to our Care team.
Posted May 29, 2025 - 18:52 CDT

Update

Performance has improved. If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need assistance, please reach out to our Care team.
Posted May 29, 2025 - 08:53 CDT

Update

Performance has improved for the majority of customers. If you are experiencing an issue with logging in or loading, retry the action a few minutes later. If you need assistance, please reach out to our Care team.
Posted May 28, 2025 - 16:28 CDT

Update

Performance has improved for the majority of customers. If you are experiencing an issue, please get in touch with our Care team for further investigation.
Posted May 28, 2025 - 08:30 CDT

Update

We continue to see improvements from our releases. If you are experiencing an issue with logging in or any other unintended behavior, please contact our Care team for further troubleshooting.
Posted May 27, 2025 - 17:09 CDT

Update

We continue to see improvements. If you are experiencing an issue, please contact our Care team for further troubleshooting.
Posted May 27, 2025 - 08:15 CDT

Update

We continue to see improvements with the intermittent performance issues. If you are experiencing an issue, please contact our Care team for further troubleshooting.
Posted May 26, 2025 - 08:15 CDT

Update

We are still seeing improvements with the intermittent performance issues and continue to keep a close eye.
Posted May 25, 2025 - 17:08 CDT

Update

We are seeing improvements with the intermittent performance issues and continue to investigate.
Posted May 25, 2025 - 08:15 CDT

Update

We are still experiencing intermittent performance issues with logging in, creating/publishing shifts, time off requests, and clocking in/out. We will provide more updates when we have them.
Posted May 24, 2025 - 17:27 CDT

Investigating

We are experiencing intermittent performance issues with logging in, creating/publishing shifts, time off requests, and clocking in/out. We are investigating the root cause of the inconsistent app performance.
Posted May 24, 2025 - 08:17 CDT

Monitoring

A fix has been implemented and we continue to monitor.
Posted May 23, 2025 - 22:46 CDT

Investigating

We are aware of issues impacting the app and are investigating further.
Posted May 23, 2025 - 21:34 CDT

Monitoring

We continue to see improvements from the fixes we have implemented and are continuing to monitor.
Posted May 23, 2025 - 16:59 CDT

Investigating

We are aware of issues impacting the app and are investigating further. We will provide an update here as soon as we have additional information.
Posted May 23, 2025 - 10:58 CDT
This incident affected: Web App, API, Login, and Website.