Workchat
Incident Report for When I Work
Resolved
Workchat is stable
Posted Mar 07, 2017 - 13:39 CST
Monitoring
We have addressed the problem and are monitoring for further issues.
Posted Mar 07, 2017 - 10:46 CST
Identified
We have identified a problem at our upstream provider and are working on a fix.
Posted Mar 07, 2017 - 10:41 CST
Investigating
We're investigating reports of problems accessing Workchat
Posted Mar 07, 2017 - 10:31 CST