Login Issue

Incident Report for When I Work

Resolved

This incident has been resolved. We apologize for the inconvenience.
Posted May 12, 2025 - 13:54 CDT

Monitoring

We identified the source of the issue and deployed a fix. We are now monitoring to ensure its success.
Posted May 12, 2025 - 13:45 CDT

Investigating

We are investigating an issue impacting the ability to log into When I Work.
Posted May 12, 2025 - 13:42 CDT
This incident affected: Web App and Login.