AWS Incident

Incident Report for When I Work

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:39 CDT

Update

Our team continues to monitor the performance of our app as AWS works to fully resolve their incident.
Posted Oct 20, 2025 - 18:07 CDT

Update

Our team is still monitoring our app after being impacted by the ongoing AWS incident. If you are having any issues, please reach out to our Care team for assistance.
Posted Oct 20, 2025 - 13:58 CDT

Monitoring

We are currently monitoring our app after being impacted by the AWS incident. We will provide another update as the incident is resolved. If you have questions, please reach out to our Care team.
Posted Oct 20, 2025 - 07:49 CDT
This incident affected: Web App, API, Login, Website, and Workchat.