Chat Unavailable
Incident Report for When I Work
Resolved
Chat functionality has been restored. We will continue to monitor for stability.
Posted Jul 12, 2017 - 14:32 CDT
Update
Our Chat provider is continuing to identify root cause of the outage. We apologize for the inconvenience. Please contact the Care team via support@wheniwork.com. Thank you!
Posted Jul 12, 2017 - 13:26 CDT
Identified
Our Chat provider is currently experiencing an outage. The Care team can be reached at support@wheniwork.com.

Updates will be provided as they become available.
Posted Jul 12, 2017 - 08:05 CDT